Zypper will nicht installieren

Ihr werdet ja alle in den nächsten paar Jahren herausfinden, daß OpenSuse die Weltherrschaft bei den Betriebssystemen übernommen haben wird. Deswegen werde ich an dieser Stelle mal ein paar nerdige Themen zu Suse posten.

Was mich schon ein Weilchen irritiert hat, war die Meldung von zypper:

 # zypper up
Daten des Repositories laden ...
Installierte Pakete lesen ...

The following 52 package updates will NOT be installed:
  apper apper-lang avrdude ...

Das ist dann ja schon irgendwie blöd, wenn der zypper mir sagt, daß er da schon neuere Pakete hat, die aber absichtlich, nur um MICH zu ärgern, nicht installiert!

Das ganze klärt sich, wie das ganze Leben, nach einer kurzen Webrecherche auf. zypper up darf die Paketquelle nicht wechseln. Mit zypper dup klappt’s dann auch mit den neuen Paketen und alles wird gut.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.